Fort Dodge Fiber - 20251216 - Internet Issues for our 1G Residential Customers – Incident details

All systems operational

20251216 - Internet Issues for our 1G Residential Customers

Resolved
Major outage
Started 2 days agoLasted about 12 hours

Affected

Internet

Major outage from 8:49 AM to 9:09 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. As of 12:30pm today, we believe we have resolved all of our issues, and sincerely apologize for the disruption of service. Clearly, things do not always go as planned, and we worked as quickly as possible to resolve the issues, while keeping our customers aware of the issues.

    Again, we apologize for inconvenience!

    If you are still experiencing any issues, please contact our 24/7 support line at 515-515-5111.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. We do apprecaite your patience!

  • Investigating
    Investigating

    We had an issue with our Nokia updates tonight from our Midnight - 2AM maintenance windows that affected our 1G residential customers. We are working to resolve these issues, and will restore service as fast as possible.