Fort Dodge Fiber - Internet connectivity issues - 20250819 – Incident details

All systems operational

Internet connectivity issues - 20250819

Resolved
Operational
Started 14 days agoLasted about 6 hours

Affected

Internet

Partial outage from 2:49 PM to 3:26 PM, Operational from 3:26 PM to 9:13 PM

Phone

Partial outage from 2:49 PM to 3:26 PM, Operational from 3:26 PM to 9:13 PM

Updates
  • Resolved
    Resolved

    All issues have been resolved.

    Our team was staging a new firmware for our equipment to begin testing BEFORE deployment, but was inadvertently triggered to download and update all of our connected equipment. Because we had not yet fully tested this new firmware on our equipment, we will be rolling back the devices tonight during our already schedule maintenance window.

    Firmware updates will always be tested BEFORE being deployed, and that deployment will in almost all cases happen during the middle of the night.

    We apologize for this issue, and wish to thank you for your patience.

  • Monitoring
    Monitoring

    We have identified the issue, and are determining the best steps to make sure this does not happen again. We believe our services have returned to normal. We will continue to monitor the issue, and update this issue as we know more.

    We apologize for the inconvenience, and thank you for your patience!

  • Investigating
    Investigating

    We are currently investigating connectivity issues. As soon as we know more, we will update this case.

    We apologize for the inconvenience!