Fort Dodge Fiber - 20250818 - Internet Issues... – Incident details

All systems operational

20250818 - Internet Issues...

Resolved
Partial outage
Started 16 days agoLasted about 8 hours

Affected

Internet

Partial outage from 1:25 PM to 1:37 PM, Operational from 1:37 PM to 9:38 PM

Phone

Partial outage from 1:25 PM to 1:37 PM, Operational from 1:37 PM to 9:38 PM

Updates
  • Resolved
    Resolved

    We believe we have resolved the issues from this morning that affected most of our customers. We do have a maintenance window scheduled for 12am on Wednesday the 20th to help combat the issue we experienced, and test some failover scenarios. Our goal is to have fully redundant systems, so our customers will not experience issues when things like this happen.

    We appreciate your patience, and apologize for the inconvenience!

  • Monitoring
    Monitoring

    We have isolated the issue, and believe we have all of our service back up and running again. We will continue to monitor this issue throughout the day. Thanks again for your patience!

  • Investigating
    Investigating

    We are investigating issues with our Internet connectivity. We appreciate your patience as we work to resolve these issues.