Fort Dodge Fiber - 20250512 - Phone Issues... – Incident details

All systems operational

20250512 - Phone Issues...

Resolved
Operational
Started about 1 month agoLasted about 16 hours

Affected

Phone

Operational from 9:15 PM to 1:13 PM

Updates
  • Resolved
    Resolved

    As of 10:10 pm CDT last night, May 12, our voice provider has confirmed these issues have been resolved.

  • Monitoring
    Monitoring

    Our voice provider has implemented a fix for the issue, and we will be monitoring our voice services for any continued issue.

  • Investigating
    Investigating

    Our voice provider has advised us of inbound and outbound calling issues. Our voice provider is working on identifying the problem and resolving it as quickly as they can. I will update this as soon as we know more.