Scheduled for February 20, 2025 at 6:00 AM – 9:00 AM
Affects
Internet
Under maintenance from 6:00 AM to 9:00 AM
Phone
Under maintenance from 6:00 AM to 9:00 AM
Updates
Completed
February 20, 2025 at 9:00 AM
Completed
February 20, 2025 at 9:00 AM
Maintenance has completed successfully
In progress
February 20, 2025 at 6:00 AM
In progress
February 20, 2025 at 6:00 AM
Maintenance is now in progress
Planned
February 20, 2025 at 6:00 AM
Planned
February 20, 2025 at 6:00 AM
This is a scheduled maintenance window to update routing and redundancy policy configurations in our IP routing infrastructure. Service outages will occur during the 3 hour window, but we will do our best to keep the downtime to minimum.