Scheduled for October 17, 2024 at 3:00 PM – 5:00 PM
Affects
Internet
Under maintenance from 3:00 PM to 5:00 PM
Phone
Under maintenance from 3:00 PM to 5:00 PM
Completed
October 17, 2024 at 5:00 PMCompleted
October 17, 2024 at 5:00 PMMaintenance has completed successfully
In progress
October 17, 2024 at 3:00 PMIn progress
October 17, 2024 at 3:00 PMMaintenance is now in progress
Planned
October 17, 2024 at 3:00 PMPlanned
October 17, 2024 at 3:00 PMWe are planning for a scheduled maintenance during that time. We do not expect any outages during this window, but there may be some brief periods of slowness as these updates are implemented. Thank you for your patience and understanding.