Scheduled for December 16, 2025 at 6:00 AM – 8:00 AM
Affects
Internet
Under maintenance from 6:00 AM to 8:00 AM
Phone
Under maintenance from 6:00 AM to 8:00 AM
Completed
December 16, 2025 at 8:00 AMCompleted
December 16, 2025 at 8:00 AMMaintenance has completed successfully
In progress
December 16, 2025 at 6:00 AMIn progress
December 16, 2025 at 6:00 AMMaintenance is now in progress
Planned
December 16, 2025 at 6:00 AMPlanned
December 16, 2025 at 6:00 AMOur network team will be updating our Nokia wireless routers tonight at midnight, lasting 2 hours. We will be updating devices in batches, scattered throughout the maintenance window. When your equipment is updated, it should reboot and come back up automatically.
If you experience issues after 2am on Tuesday, December 16th, before calling our tech support team, please turn off your Nokia equipment, count to 30, and then turn it back on. After turning the equipment back on, please allow the equipment 5 minutes to boot up and get in sync with our network. If you are still having issues at that time, do not hesitate to call into our tech support team at 515-515-5111.
Thanks for your patience and understanding!